문제
독일 로또는 {1, 2, ..., 49}에서 수 6개를 고른다.
로또 번호를 선택하는데 사용되는 가장 유명한 전략은 49가지 수 중 k(k>6)개의 수를 골라 집합 S를 만든 다음 그 수만 가지고 번호를 선택하는 것이다.
예를 들어, k=8, S={1,2,3,5,8,13,21,34}인 경우 이 집합 S에서 수를 고를 수 있는 경우의 수는 총 28가지이다. ([1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ..., [3,5,8,13,21,34])
집합 S와 k가 주어졌을 때, 수를 고르는 모든 방법을 구하는 프로그램을 작성하시오.
입력
입력은 여러 개의 테스트 케이스로 이루어져 있다. 각 테스트 케이스는 한 줄로 이루어져 있다. 첫 번째 수는 k (6 < k < 13)이고, 다음 k개 수는 집합 S에 포함되는 수이다. S의 원소는 오름차순으로 주어진다.
입력의 마지막 줄에는 0이 하나 주어진다.
출력
각 테스트 케이스마다 수를 고르는 모든 방법을 출력한다. 이때, 사전 순으로 출력한다.
각 테스트 케이스 사이에는 빈 줄을 하나 출력한다.
예제 입력 1
7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0
예제 출력 1
1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7
1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34
💛 나의 풀이
import java.io.*;
class Main {
static int[] S;
static int k; // 집합 S의 길이
static boolean[] visited;
public static void main(String[] args) throws IOException{
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
while(true){
String[] num=br.readLine().split(" ");
if(num[0].equals("0")) break; // 0을 입력받으면 break
k=Integer.parseInt(num[0]);
S=new int[k]; // k만큼 배열 길이
visited=new boolean[k];
for(int i=0; i<k; i++){
S[i]=Integer.parseInt(num[i+1]); // S에 원소 추가
}
dfs(0, 0);
System.out.println();
}
}
public static void dfs(int start, int depth){
if(depth == 6){
for(int i=0; i<k; i++){
if(visited[i]) System.out.print(S[i]+" ");
}
System.out.println();
return;
}
for(int i=start; i<k; i++){
visited[i]=true;
dfs(i+1, depth+1);
visited[i]=false;
}
}
}
백트래킹 문제
정렬을 하기위해 start를 매개변수로 넣어 start 인덱스부터 시작되게 한다.
입력 받은 S가 오름차순 정렬 되어있음
visited를 왜 쓰는지 느꼈다. visited 대신 contains를 쓰니 이상하게 작동한다 ..
depth가 6이 되어서 출력할 때도 visited에 값이 true인 인덱스의 값을 출력한다.
// 실패
import java.io.*;
import java.util.*;
class Main {
static int[] S;
static int k;
static int[] lotto;
static ArrayList<int[]> ans=new ArrayList<>();
public static void main(String[] args) throws Exception{
while(true){
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
String[] num=br.readLine().split(" ");
if(num[0].equals("0")) break; // break 안되는데 '0'과 "0"이 달라
k=Integer.parseInt(num[0]);
S=new int[k]; // k만큼 배열 길이
for(int i=0; i<k; i++){
S[i]=Integer.parseInt(num[i+1]); // S에 원소 추가
}
lotto=new int[6]; // 6개 숫자 담기
dfs(0);
System.out.println(ans.size());
}
}
public static void dfs(int depth){
if(depth == 6){
ans.add(lotto);
return;
}
for(int i=0; i<k; i++){
System.out.println(Arrays.asList(lotto).contains(S[i]));
if(!Arrays.asList(lotto).contains(S[i])){ // 중복x, s[i]가 lotto에 없으면 추가
lotto[depth]=S[i];
dfs(depth+1);
}
}
}
}
🦒 다른 사람 풀이
// https://log-laboratory.tistory.com/118
import java.io.*;
import java.util.*;
class Main {
static int N;
static int[] arr;
static boolean[] result;
public static void main(String[] args) throws IOException{
Scanner sc=new Scanner(System.in);
while(true){
N=sc.nextInt();
if(N == 0) break;
arr=new int[N];
result=new boolean[N];
for(int i=0; i<N; i++) arr[i]=sc.nextInt();
DFS(0, 0);
System.out.println();
}
}
private static void DFS(int start, int depth){
if(depth == 6){
for(int i=0; i<N; i++){
if(result[i]){
System.out.print(arr[i]+" ");
}
}
System.out.println();
}
for(int i=start; i<N; i++){
result[i]=true;
DFS(i+1, depth+1);
result[i]=false;
}
}
}
Scanner로 입력을 받는다.
// https://drcode-devblog.tistory.com/242
import java.io.*;
class Main {
static int N;
static int[] arr;
static boolean[] check;
static BufferedWriter bw=new BufferedWriter(new OutputStreamWriter(System.out));
public static void main(String[] args) throws IOException{
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
while(true){
String[] str=br.readLine().split(" ");
if("0".equals(str[0])) break;
N=Integer.parseInt(str[0]);
arr=new int[N];
check=new boolean[N];
for(int i=0; i<arr.length; i++) arr[i]=Integer.parseInt(str[i+1]);
find(0, 0);
bw.write("\n");
}
bw.flush();
}
public static void find(int start, int depth) throws IOException{
if(depth == 6){
for(int i=0; i<N; i++){
if(check[i]){
bw.write(arr[i]+ " ");
}
}
bw.write("\n");
return;
}
for(int i=start; i<N; i++){
check[i]=true;
find(i+1, depth+1);
check[i]=false;
}
}
}
BufferedWriter를 이용해서 출력을 한꺼번에 한다.
효율이 좋다.
문제 출처 👉 백준
'coding test' 카테고리의 다른 글
[Java] 2023. 신기한 소수 (0) | 2021.09.01 |
---|---|
[Java, Python] 1759. 암호 만들기 (0) | 2021.08.31 |
[Java] 9095. 1, 2, 3 더하기 (0) | 2021.08.30 |
[Java] 9663. N-Queen (0) | 2021.08.29 |
[Java] 15649. N과 M (1) (0) | 2021.08.29 |