coding test

[파이썬] 1182. 부분수열의 합

잔망루피 2021. 9. 25. 21:13

문제

N개의 정수로 이루어진 수열이 있을 때, 크기가 양수인 부분수열 중에서 그 수열의 원소를 다 더한 값이 S가 되는 경우의 수를 구하는 프로그램을 작성하시오.

입력

첫째 줄에 정수의 개수를 나타내는 N과 정수 S가 주어진다. (1 ≤ N ≤ 20, |S| ≤ 1,000,000) 둘째 줄에 N개의 정수가 빈 칸을 사이에 두고 주어진다. 주어지는 정수의 절댓값은 100,000을 넘지 않는다.

출력

첫째 줄에 합이 S가 되는 부분수열의 개수를 출력한다.

예제 입력 1

5 0

-7 -3 -2 5 8

예제 출력 1

1

 

 

🐝 나의 풀이

N, S=map(int, (input().split()))  # 정수의 개수, 정수
lst=list(map(int, input().split()))     # N개의 정수
answer=0

for i in range(1,1<<N) :     # 부분집합의 개수
    total=0
    for j in range(N) :
        if i & 1<<j :
            total+=lst[j]
    if total == S :
        answer+=1

print(answer)

비트마스크 풀이

비트마스크 처음 공부했다 ㅎ

i가 3이라면 j가 0, 1일 때 i에 포함된다. 

i는 2진수로 011이다. 1<<0은 001, 1<<1은 010이다. 2^0과 2^1 비트가 켜져있다.

왜 실행시간이 4080ms나 걸린거지 ㅜ.ㅜ

 

 

# 실패
N, S=map(int, (input().split()))  # 정수의 개수, 정수
lst=list(map(int, input().split()))     # N개의 정수
answer=0

# 합이 S가 되는 부분수열의 개수 구하기
def dfs(start, depth, cnt, num):
    global answer
    if depth == cnt:  # 부분집합의 개수
        if S == num:  # 합이 S라면
            answer += 1
        return

    for i in range(start, N):
        if not visited[i] :
            visited[i]=True
            dfs(i, depth, cnt + 1, num + lst[i])

for i in range(1,N+1) :     # 부분집합의 개수
    for j in range(N) :
        visited = [0] * N
        dfs(j, i, 0, 0)     # 시작점, 반복횟수, 현재반복횟수, 합계

print(answer)

문제의 테케는 통과했지만 제출하니까 실패 ㅠ

원소의 개수가 1부터 N까지의 부분집합을 만들었다.

j는 시작점이고, 부분집합의 원소의 개수 depth가 되면 합계 S와 같은지 확인한다.

 

 

🐹 다른 사람 풀이

// https://hongjw1938.tistory.com/114?category=925707
import java.io.*;

public class Main{
    static int n;
    static int s;
    static int num[];
    static int ans=0;
    static int sum=0;

    public static void main(String[] args) throws IOException{
        BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw=new BufferedWriter(new OutputStreamWriter(System.out));

        String line[]=br.readLine().split(" ");
        n=Integer.parseInt(line[0]);
        s=Integer.parseInt(line[1]);

        num=new int[n];
        line=br.readLine().split(" ");

        for(int i=0; i<n; i++){
            num[i]=Integer.parseInt(line[i]);
        }

        // 재귀함수 시작
        backTrack(0, 0);

        bw.write(String.valueOf(ans));
        bw.flush();
        br.close();
    }

    public static void backTrack(int idx, int ch){
        // 0개 이상의 수가 선택되었고 그 합이 s와 같다면
        if(ch > 0 && sum == s){
            ans++;
        }

        // idx번째 숫자부터 시작하여 나머지 수들을 재귀로 체크
        for(int i=idx; i<n; i++){
            sum+=num[i];
            backTrack(i+1, ch+1);
            sum-=num[i];
        }
    }
}

idx는 시작 인덱스다.

ch가 0보다 크고, 합계가 s가 되면 부분수열의 개수 ans를 증가시킨다.

끝까지 간 후에는 sum-=num[i]가 실행되며 백트래킹이 일어난다.

n까지가 끝이라서 return을 쓸 필요가 없다.

나처럼 1부터 n까지 함수를 호출할 필요가 없구나..!

 

 

// https://hongjw1938.tistory.com/114?category=925707
import java.io.*;

public class Main{
    static int n;
    static int s;
    static int num[];
    static int ans=0;

    public static void main(String[] args) throws IOException{
        BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw=new BufferedWriter(new OutputStreamWriter(System.out));

        String line[]=br.readLine().split(" ");
        n=Integer.parseInt(line[0]);
        s=Integer.parseInt(line[1]);

        num=new int[n];
        line=br.readLine().split(" ");

        for(int i=0; i<n; i++){
            num[i]=Integer.parseInt(line[i]);
        }

        // 1부터 시작하여 전체 비트가 1이 되는 모든 경우의 수에 대해 확인
        for(int i=1; i<(1<<n); i++){
            int sum=0;

            // 1을 0~n-1번 비트를 좌측으로 밀어서 현재 포함된 숫자가 무엇인지를 전체 탐색
            for(int j=0; j<n; j++){
                // 만약 0이 아니라면 j번째 수는 현재 포함된 것
                if((i&(1<<j)) != 0){
                    sum+=num[j];
                }
            }
            if(sum == s) ans++;
        }

        bw.write(String.valueOf(ans));
        bw.flush();
        br.close();
    }
}

비트마스크 풀이

비트마스크로 풀면 정말 간결하게 코드를 작성할 수 있다.

 

 

# https://esoongan.tistory.com/79
import sys
input=sys.stdin.readline
from itertools import combinations

n, s=map(int, input().split())
data=list(map(int, input().split()))

count=0

for i in range(1, n+1) :
    per=combinations(data, i)
    for j in list(per) :
        if sum(j) == s :
            count+=1

print(count)

combinations 메소드를 이용해 1부터 n까지 길이를 가지는 조합을 만든다.

파이썬에서 1초에 대략 2천만번의 연산을 한다고 한다.

N이 최대 20이므로 2^20=1,048,576

combinations를 사용하는 것은 간단한 방법이지만 입력의 크기가 커지면 효율성 땜에 쓸 수가 없다..

 

 

# https://esoongan.tistory.com/79
import sys
input=sys.stdin.readline

n, s=map(int, input().split())
s_=list(map(int, input().split()))
cnt=0

def dfs(idx, sum) :
    global cnt
    if idx >= n :
        return
    sum+=s_[idx]
    if sum == s :
        cnt+=1
    dfs(idx+1, sum-s_[idx])
    dfs(idx+1, sum)

dfs(0, 0)
print(cnt)

dfs로 구현

idx가 정수의 개수 n과 같아지면 return한다.

 

 

 

문제 출처 👉 백준

 

반응형